Bug #191

Access violation when editing club keys (new release v1.3.26)

Added by Walter Pate about 8 years ago. Updated about 8 years ago.

Status:ClosedStart date:04/25/2014
Priority:NormalDue date:
Assignee:Jamie Pate% Done:

0%

Category:Registration, feature keysSpent time:13.00 h
Target version:1.3.26

Description

Testing version release 1.3.26rc6 msi on windows 8 gives an unexplained access violation error.when you click OK the program continues

Access violation when editing club keys.jpg (38.3 KB) Walter Pate, 04/25/2014 12:39 PM

Alter Table repair.jpg (168 KB) Walter Pate, 04/25/2014 03:09 PM

full screen shot.jpg (189 KB) Jamie Pate, 04/26/2014 01:54 PM

History

#1 Updated by Jamie Pate about 8 years ago

Please add a more detailed step by step summary of how to reproduce this issue.

#2 Updated by Walter Pate about 8 years ago

I found this error by going into the Club initial box and back spacing the initials entered in the box. the violation appears it seems every time.
I restored the NGQMA test database that I have been using and sent you earlier(diong this I Found a database repair of duplicate entry, see attached file) and it still brings up the access violation

#3 Updated by Jamie Pate about 8 years ago

Duplicate entry is fine in this case, usually these messages can be ignored.

#4 Updated by Jamie Pate about 8 years ago

it'd be nice if the screenshot included more context (pages in the background, all the checkboxes etc on the options page)

#5 Updated by Jamie Pate about 8 years ago

So far i'm unable to reproduce this. Could you export your registry?
The key is HKEY_CURRENT_USER\Software\Mosco\moscore_qm
http://technet.microsoft.com/en-us/library/cc755091.aspx

#6 Updated by Walter Pate about 8 years ago

  • File full screen shot.jpg added

In this screen shot I backspaced on the C of the club name GSQMRC and the error popped up. I switche to the race registration page and the same thing happened

#7 Updated by Jamie Pate about 8 years ago

  • File deleted (full screen shot.jpg)

#8 Updated by Jamie Pate about 8 years ago

Masked club key in screenshot.

#9 Updated by Walter Pate about 8 years ago

I uninstalled Moscore, deleted required AppData ,programdata and programfiles (x86) files
reinstalled moscore. Program starts in demo mode OK can restart program every time
when I change club club id and enter numbers for subscription code I get the exception code.
if the program is closed then restarted it bombs after the splash screen have to uninstall and start over again in demo mode

#10 Updated by Walter Pate about 8 years ago

  • Status changed from New to In Progress
I found a way to replicate issue
  • Uninstall Moscore QM
  • Delete Program Data/Mysql/Data/Moscore-QM
  • Reinstall Moscore-QM which will start in Demo Mode
  • Enter new Club Initial
  • Enter club key that matches the club initial

as soon as you enter the last character in the club key the access violation window pops up
I skyped you earlier because I proposed it may be the sequence that Moscore accepts club keys for scoreboards custom features. I tested a club key of RMQMA which is Moscore-QM Lite no scoreboard and it still did the access violation

From this information is it possible the problem is in the Mysql database moscore-QM?

#11 Updated by Jamie Pate about 8 years ago

Able to reproduce in virtual machine.
Please note that deleting just the moscore_qm folder from the mysql\data folder is not advisable. There are other files in mysql\data that contain data for that database!

If you are going to delete folders manually it's best to delete the entire programdata\mysql directory.

This may be related to the build as it was built as a release build and most builds have been debug builds in the past. I will try substituting a debug build to see if it masks the issue.

#12 Updated by Jamie Pate about 8 years ago

Confirmed, debug build does not have this issue.

Will investigate further.

#13 Updated by Jamie Pate about 8 years ago

  • Status changed from In Progress to Resolved

#14 Updated by Walter Pate about 8 years ago

  • Status changed from Resolved to Closed
  • Target version changed from 1.3.27 to 1.3.26

Tested on Win 7 and Win 8.1 machine, full version and .msi version
Test OK could change club keys and set program back to Demo mode

Also available in: Atom PDF