Bug #317

Can not start webserver on basic subscription

Added by Walter Pate almost 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:03/14/2017
Priority:NormalDue date:
Assignee:Jamie Pate% Done:

0%

Category:WebserverSpent time:4.00 h
Target version:1.3.40

Description

getting socket already in use error

History

#1 Updated by Walter Pate almost 5 years ago

I tried on several computers and the webserver is always giving a Database is not authorized to run the webserver message, even though the webserver key is entered.
This only happens if the customer has a Basic Subscription Key entered. If I put in a Gold Subscription key the Webserver works

#2 Updated by Jamie Pate almost 5 years ago

That's probably because the database is not authorized unless they have the web server key also. The web server is included in the gold package.

FYI: The web server also doesn't respect the grace period for the previous year's subscription key, so it will not be authorized until the subscription is updated to the current year.

The actual bug you reported here 'socket is already in use' could be skype, or perhaps you have tried to start the web server multiple times.

#3 Updated by Walter Pate almost 5 years ago

I installed feature keys for the webserver using the Add A Feature Code button. the code is entered and MSQM Webserver box is checked
I also have the X2 feature added in the same fashion. It gives the message with Tranx as well as with X2. But if I input the Gold Subscription code it works fine

#4 Updated by Jamie Pate almost 5 years ago

  • Status changed from New to Resolved
  • Target version changed from Future to 1.3.40

Fixed in 1.3.40

#5 Updated by Walter Pate almost 5 years ago

  • Status changed from Resolved to Closed

The webserver feature works with a valid Basic or Gold subscription now

Also available in: Atom PDF